poj2499(逆向找根,用迭代相除法来优化)

POJ-2499 Binary Tree
Time Limit: 1000 ms / Memory Limit: 65536 kb
Description
Background
Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:

The root contains the pair (1, 1).
If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem
Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right child?
Input
The first line contains the number of scenarios.
Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent
a node (i, j). You can assume that this is a valid node in the binary tree described above.

Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.

Sample Input
3
42 1
3 4
17 73
Sample Output
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6
Source
None

一直减的话会超时,嗨,原来一次一次的减变成相除就变得很容易,还有一个点,没有逆向思维,一直想的是根找目标节点,想找找规律,但是真的很烦,反一下,目标节点找根就会变得异常容易

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
typedef long long LL;
int main()
{
    int t;
    scanf("%d",&t);
    LL n,m;
    int k = 1;
    while(t--)
    {
        int left = 0;
        int right = 0;
        scanf("%lld %lld",&n,&m);
        printf("Scenario #%d:\n",k++);
        while(true)
        {
            if(n == 1 && m == 1){
                break;
            }
            if(n > m){
                int t;
                if(m == 1) t = n - m;
                else t = n / m;
                n = n - t * m;
                left += t;
            }
            else{
                int t;
                if(n == 1) t = m - n;
                else t = m / n;
                right += t;
                m -= t * n;
            }
        }
        printf("%d %d\n",left,right);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/80052518