hdu 5912 Fraction(简单模拟)

题目链接
Mr. Frog recently studied how to add two fractions up, and he came up with an evil idea to trouble you by asking you to calculate the result of the formula below:
在这里插入图片描述
As a talent, can you figure out the answer correctly?

Input
The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains only one integer n (n≤8).

The second line contains n integers: a1,a2,⋯an(1≤ai≤10).
The third line contains n integers: b1,b2,⋯,bn(1≤bi≤10).

Output
For each case, print a line “Case #x: p q”, where x is the case number (starting from 1) and p/q indicates the answer.

You should promise that p/q is irreducible.

Sample Input
1
2
1 1
2 3

Sample Output
Case #1: 1 2

Hint
Here are the details for the first sample:
2/(1+3/1) = 1/2

Source
2016中国大学生程序设计竞赛(长春)-重现赛

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=1e5+1;
int T,n;
ll t,a[maxn],b[maxn];
int main()
{
    scanf("%d",&T);
    for(int j=1;j<=T;++j)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;++i) scanf("%lld",&a[i]);
        for(int i=1;i<=n;++i) scanf("%lld",&b[i]);
        ll temp1=b[n],temp2=a[n];
        for(int i=n-1;i>=1;--i)
        {
            temp1+=temp2*a[i];
            swap(temp1,temp2);
            temp1*=b[i]; 
        }
        ll g=__gcd(temp1,temp2);
        printf("Case #%d: %lld %lld\n",j,temp1/g,temp2/g);
    }
}
发布了171 篇原创文章 · 获赞 0 · 访问量 5803

猜你喜欢

转载自blog.csdn.net/qq_42479630/article/details/104591104