背包模板题Charm Bracelet

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23

思路:表示在前i种物品中取若干种,在其总体积不超过M的条件下所能获得的最大价值。 
在这里插入代码片
#include"cstdio"
#include"cstring"
#include"algorithm"
#include"cmath"
using namespace std;
int dp[12905];
int w[5000],v[5000];
int main()
{	
	int n,m;
	while(~scanf("%d %d",&n,&m))
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d %d",&w[i],&v[i]);
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=m;j>=w[i];j--)
			{
				dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}


发布了76 篇原创文章 · 获赞 1 · 访问量 2773

猜你喜欢

转载自blog.csdn.net/weixin_44824383/article/details/102939474