背包问题——01背包问题——Charm Bracelet

Charm Bracelet

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.
Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
Output
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int w[3500],d[3500];
int f[13000];
int main()
{
 	int n,m;
 	scanf("%d%d",&n,&m);
 	memset(f,0,sizeof(f));
 	for(int i=1;i<=n;i++)
 		scanf("%d%d",&w[i],&d[i]);
 	for(int i=1;i<=n;i++)
  		for(int v=m;v>=1;v--)
  		{
   			if(v>=w[i])
    				f[v]=max(f[v],f[v-w[i]]+d[i]);
  		}
 	printf("%d\n",f[m]);
 	return 0;
}
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int w[3500],d[3500];
int f[13000];
int main()
{
       int n,m;
       scanf("%d%d",&n,&m);
       memset(f,0,sizeof(f));
       for(int i=1;i<=n;i++)
              scanf("%d%d",&w[i],&d[i]);
       for(int i=1;i<=n;i++)
              for(int v=m;v>=1;v--)
              {
                     int a;
                     if(v>=w[i])
                            a=f[v-w[i]]+d[i];
                     else
                            a=0;
                     f[v]=f[v]>a?f[v]:a;
              }
       printf("%d\n",f[m]);
       return 0;
}


猜你喜欢

转载自blog.csdn.net/weixin_43613299/article/details/85856626