ALGO-279 相邻数对

资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
  给定n个不同的整数,问这些数中有多少对整数,它们的值正好相差1。
输入格式
  输入的第一行包含一个整数n,表示给定整数的个数。
  第二行包含所给定的n个整数。
输出格式
  输出一个整数,表示值正好相差1的数对的个数。
样例输入
6
10 2 6 3 7 8
样例输出
3
样例说明
  值正好相差1的数对包括(2, 3), (6, 7), (7, 8)。
评测用例规模与约定
  1<=n<=1000,给定的整数为不超过10000的非负整数。

#include <iostream>
using namespace std;
#include <set>
int main()
{
	int num;
	cin >> num;
	set<int> s;//用stl中的set存放
	for (int i = 0; i < num; i++) {
		int k;
		cin >> k;
		s.insert(k);
	}
	int count = 0;
	set<int>::iterator it = s.begin();
	it++;
	for (set<int>::iterator itt = s.begin(); it != s.end(); itt++, it++) {//it和itt是两个迭代器
		if ((*it - *itt) == 1)
		{
			count++;
		}
	}
	cout << count << endl;

	return 0;
}

发布了30 篇原创文章 · 获赞 9 · 访问量 1317

猜你喜欢

转载自blog.csdn.net/weixin_43625164/article/details/105352915