PAT--1120 Friend Numbers (20 分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

代码:

#include <iostream>
#include <bits/stdc++.h>

using namespace std;

int sumNum(int x)
{
    int sum = 0;
    while(x!=0)
    {
        sum+=x%10;
        x = x/10;
    }
    return sum;
}

int main()
{
    int n;
    set<int> out;
    cin>>n;
    int a[n];
    int sum[n];
    for(int i=0; i<n; i++)
    {
        cin>>a[i];
        sum[i] = sumNum(a[i]);
        out.insert(sum[i]);
    }

    cout<<out.size()<<endl;
    for(set<int>::iterator it = out.begin(); it!=out.end(); it++)
    {
        if(it==out.begin())
            cout<<*it;
        else
            cout<<" "<<*it;
    }
    cout<<endl;


}

 分析:

直接使用set存储“朋友”(set存储有序且不重复的数),就是访问的时候有点麻烦,set只能使用迭代器进行访问;

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/98519600