PAT 1120 Friend Numbers (20)

1120 Friend Numbers (20)(20 分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10​4​​.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

 思路:

因为最后要的是这些数字每一位加起来的和,而和会重复,所以想到了用set,set可以自动去掉重复的元素。只要每次求出一个数字相应的各位和,插入set,最后的时候set的size就是和的个数,set里面的内容就是不重复的和。一直以为set没啥用,没想到还真给我用到一次_(:з」∠)_

代码:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>  
#include <set>
using namespace std;

set<int> s;

int main()
{
	int n, num, sum;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> num;
		sum = 0;
		while (num)
		{
			sum += num % 10;
			num /= 10;
		}
		s.insert(sum);
	}
	n = s.size();
	cout << n << endl;
	for (set<int>::iterator iter = s.begin(); iter != s.end(); iter++)
	{
		n--;
		cout << *iter ;
		if (n)
			cout << " ";
	}		
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ryo_218/article/details/81512454