PAT(A) 1120. Friend Numbers (20)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79517627

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1120

1120. Friend Numbers (20)


Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them. Note: a number is considered a friend of itself.

Input Specification:

**Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:
8
123 899 51 998 27 33 36 12
Sample Output:
4
3 6 9 26

题目大意

若两个数字的各数位和相等,称这两个数为好友数。各数位和为好友id,现给出各个数,求好友id数量,并增序输出好友id

解题报告

在读入的时候,计算好友id并存入set中,set有自动排序的功能。

代码

/*
* Problem: 1120. Friend Numbers (20)
* Author: HQ
* Time: 2018-03-11
* State: Done
* Memo: set的应用
*/
#include "iostream"
#include "set"
using namespace std;

set<int> friendId;
int N;

int getSum(int x) {
    int s = 0;
    while (x) {
        s += x % 10;
        x /= 10;
    }
    return s;
}

int main() {
    cin >> N;
    int x;
    for (int i = 0; i < N; i++) {
        cin >> x;
        friendId.insert(getSum(x));
    }
    cout << friendId.size() << endl;
    bool first = true;
    for (set<int>::iterator it = friendId.begin(); it != friendId.end(); it++) {
        if (first) {
            cout << *it;
            first = false;
        }
        else
            cout << " " << *it;
    }
    cout << endl;
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79517627