Monkey and Banana HDU - 1069(动归)

Monkey and BananaHDU - 1069

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
分析:

一个长方体对应六种矩形,将矩形按照所谓的长排序,长相同则按宽排序;这样做的好处是,可以放在一个矩形上面的矩形都在这个矩形的同一边,那么类似于序列dp,可以设dp[i]为第i个矩形是最后一个的时候的最大高度

有:dp[i]=max{h+dp[j]}(j矩形可以放在i矩形上)

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<stack>   
#include<set>  
#include<bitset>  
#include<list>

#define UP(i,x,y) for(int i=x;i<=y;i++)  
#define DOWN(i,x,y) for(int i=x;i>=y;i--)  
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a) 
#define ll long long  
#define INF 0x3f3f3f3f  
#define EXP 1e-10  
#define lowbit(x) (x&-x)
 
using namespace std;
struct node{
	int l,s,h;
	node(int l,int s,int h):l(l),s(s),h(h){}
	bool operator < (const node& n)const{
		if(l==n.l)return s<n.s;
		return l<n.l;
	}
};
vector<node> v;
int dp[200];
int main(){
	int n,kase=0;
	cin>>n;
	while(n!=0){
		kase++;
		v.clear();
		MEM(dp,0);
		int num=0;
		int a,b,c;
		for(int i=1;i<=n;i++){
			cin>>a>>b>>c;
			v.push_back(node(a,b,c));
			v.push_back(node(a,c,b));
			v.push_back(node(b,a,c));
			v.push_back(node(b,c,a));
			v.push_back(node(c,a,b));
			v.push_back(node(c,b,a));
		}
		sort(v.begin(),v.end());
		int cmax=-INF;
		for(int i=0;i<v.size();i++){
			dp[i]=v[i].h;
			for(int j=i-1;j>=0;j--){
				if(v[j].l<v[i].l&&v[j].s<v[i].s&&dp[j]+v[i].h>dp[i]){
					dp[i]=dp[j]+v[i].h;
				}
			}
			if(dp[i]>cmax)cmax=dp[i];
		}
		cout<<"Case "<<kase<<": maximum height = "<<cmax<<endl;
		cin>>n;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333528/article/details/80515105