POJ1047-Round and Round We Go

Description

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a”cycle”of the digits of the original number. That is, if you consider the number after the last digit to “wrap around”back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table:
142857 *1 = 142857
142857 *2 = 285714
142857 *3 = 428571
142857 *4 = 571428
142857 *5 = 714285
142857 *6 = 857142

Input

Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, “01”is a two-digit number, distinct from “1” which is a one-digit number.)

Output

For each input integer, write a line in the output indicating whether or not it is cyclic.
Sample Input
142857
142856
142858
01
0588235294117647

Sample Output

142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic
0588235294117647 is cyclic

Source

Greater New York 2001

题解分析

  这是一道算法模拟题,模拟题目过程即可。核心代码是大整数乘法的部分以及结果判断的部分。这里需要注意的是判断是否符合条件时,假若不符合条件,需要在哪里跳出循环。
#include <iostream>
#include <cstdio>
using namespace std;
char str[62]={0};               //输入的长整数用字符串保存
int value[62]={0};          //把每一位都转化为整型,这样便于计算
int result[65]={0};         //用来保存计算后的结果
bool flag = false;          //这个作为判断的标志

int main()
{
    //freopen("ceshi.txt","r",stdin);
    while(scanf("%s",str)!=EOF)
    {
        flag = false;          //老样子,个人喜欢先设置不符合条件
        for(unsigned int i=0;i<strlen(str);i++)
            value[i] = str[i] - '0';
        int  n = strlen(str);
        //核心代码。简单的算数模拟。
        for(int i=2;i<=n;i++)
        {
            int r = 0;
            for(int j = n-1;j>=0;j--){
                r += value[j] * i;
                result[j] = r%10;
                r /= 10;
            }
            //以上便是大整数的乘法模拟。一个变量保存逐位乘后的结果,每次进行后result保存它mod10结果
            //对result进行检验。
            for(int j=0;j<n;j++)
            {
                if(result[j] == value[0])
                {
                    int k = j;
                    for(int l=0;l<n;l++)
                    {
                        // 一旦检测到不同立即弹出该层循环
                        if(result[k] != value[l])   break;
                        k==n-1 ? k=0 : k++;
                    }
                    if(l==n)   flag=true;
                }
            }
            if(flag==false)     break;//这个弹出也比较重要,请读者自行理解
        }
        printf("%s is %scyclic\n",str,flag==false ? "not ":"");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ishandsomedog/article/details/78940154
we