POJ 1047 Round and Round We Go

A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 
142857 *1 = 142857 
142857 *2 = 285714 
142857 *3 = 428571 
142857 *4 = 571428 
142857 *5 = 714285 
142857 *6 = 857142 
Input
Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)
Output
For each input integer, write a line in the output indicating whether or not it is cyclic.
Sample Input
142857
142856
142858
01
0588235294117647
Sample Output
142857 is cyclic
142856 is not cyclic
142858 is not cyclic
01 is not cyclic

0588235294117647 is cyclic

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
                char a[66];
                while(~scanf("%s",a))
                {
                                int b[66];
                                int num1[66];
                                int num2[66];
                                memset(num1,0,sizeof(num1));
                                int len=strlen(a);
                                for(int i=0;i<len;i++)
                                {
                                                num1[a[i]-'0']++;
                                }
                                int flag=0;
                                for(int i=2;i<=len;i++)
                                {
                                                for(int j=0;j<len;j++)
                                                b[len-1-j]=a[j]-'0';
                                                memset(num2,0,sizeof(num2));
                                                b[0]=b[0]*i;
                                                num2[b[0]%10]++;
                                                for(int j=1;j<len;j++)
                                                {
                                                                b[j]=b[j]*i+b[j-1]/10;
                                                                num2[b[j]%10]++;
                                                }
                                                //for(int j=0;j<10;j++)
                                                //cout<<num1[j]<<num2[j]<<endl;
                                                //cout<<"------"<<endl;
                                                int j;
                                                for(j=0;j<10;j++)
                                                if(num1[j]!=num2[j])break;
                                                if(j==10)flag++;
                                }
                                if(flag+1==len)printf("%s is cyclic\n",a);
                                else printf("%s is not cyclic\n",a);
                }
                return 0;
}


猜你喜欢

转载自blog.csdn.net/nihaopeng521/article/details/76175537