杭电1391

Number Steps

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,… as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.
这里写图片描述

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0…5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

思路:

(1)将所有的点视为两条直线:y=x和y=x-2,不在这两条直线上的点就输出No Number。
(2)在直线y=x上的点,横坐标x为偶数时,值为2*x(即为x+y),横坐标x为奇数时,值为2*x-1(即为x+y-1)。
(3)在直线y=x-2上的点,横坐标x为偶数时,值为x+y,横坐标x为奇数时,值为x+y-1。

AC代码:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;

int num[10005];

int main()
{
    int n,x,y;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            if((y!=x)&&(y!=x-2)) cout<<"No Number"<<endl;
            else
            {
                if(y==x)
                {
                    if(x%2==0) cout<<2*x<<endl;
                    else cout<<2*x-1<<endl;
                }
                else
                {
                    if(x%2==0) cout<<x+y<<endl;
                    else cout<<x+y-1<<endl;
                }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albert_bolt/article/details/81090038