Poj Corn Fields

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9

参考代码:

#include<stdio.h>
#include<string.h>
const int N =5000;
const int mod = 100000000;
int dp[15][N], cur[20];

// cur[i] 用来判断是否在不能种玉米的土地块上种玉米了
// cur[i] 转换成二进制,为 1 则不可以种,反之可以 
  
int ok(int x) // x 为 2进制时 是否有邻位的 1
{
    if(x&(x<<1))
	  return 0;
	  return 1;
} 

int main()
{
	int n, m, i ,j ,k, num;
	while(scanf("%d %d",&n,&m) != EOF)
	{
       memset(dp,0,sizeof(dp)); // 初始化 
	   memset(cur,0,sizeof(cur));
	   
	   for(i=1;i<=n;i++)
	    for(j=1;j<=m;j++)
	      {
	      	scanf("%d",&num);
	      	if(num==0)
	      	cur[i]+=1<<(m-j); // 更新 cur 
		  }

	   int total=1<<m;
	   for(i=0;i<total;i++)
	    {
	    	 if(ok(i)==0||(i&cur[1])) continue;
	    	 // 在相邻的两块地上种玉米 或 在不能种玉米的地上种玉米 
	    	 dp[1][i]=1;
		 }

		 
		for(i=2;i<=n;i++) { 
		  for(j=0;j<total;j++) {
		   
             if(ok(j)==0||(j&cur[i])) continue;
            // 在相邻的两块地上种玉米 或 在不能种玉米的地上种玉米 
			 else
				 for(k=0;k<total;k++) {
				    if((k&j)) // 如果和上一层的 土地相邻种植玉米 
						continue;
					dp[i][j]+=dp[i-1][k];	
			     }			    	
			 }
		 } 

		long long sum=0;
		for(i=0;i<total;i++)
		 {
		 	  sum+=dp[n][i];
		 	  sum%=mod;
		 }
		 printf("%lld\n",sum);
	} 
	 return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38737992/article/details/80418221