【HDU】4349Xiao Ming's Hope-Lucas定理推导

                        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                          Total Submission(s): 2618    Accepted Submission(s): 1795


 

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

 

Input

Each line contains a integer n(1<=n<=108)

 

Output

A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

 

Sample Input

 

1 2 11

 

Sample Output

 

2 2 8

 

Author

HIT

 

Source

2012 Multi-University Training Contest 5

 

Recommend

zhuyuanchen520   |   We have carefully selected several similar problems for you:  4340 4348 4347 4346 4345 

题目大意:求C(n,m)中有多少个奇数,m从1开始,

思路:这题是Lucas定理的推导,

首先Lucas定理:

                             C(n,m)%p=C(n/p,m/p) * C(n%p,m%p)%p

也可以写成递归形式: (C(n%p, m%p)*Lucas(n/p, m/p))%p

也就是p=2的每个式子的判断,我们可以写成二进制的形式观察,比如 n=1001101,m是从000000到1001101的枚举,我们知道在该定理中C(0,1)=0,因此如果n=1001101的0对应位置的m二进制位为1,那么C(n,m) % 2==0,因此m对应n为0的
位置只能填0,而1的位置填0,填1都是1(C(1,0)=C(1,1)=1),不影响结果为奇数,并且保证不会
 出n的范围,因此所有的情况即是n中1位置对应m位置0,1的枚举,那么结果很明显就是:2^(n中1的个数)

代码:

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int n,cnt;
    while(cin>>n)
    {
        cnt=0;
        while(n)
        {
            cnt+=n%2;
            n>>=1;
        }
        printf("%d\n",1<<cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/81667611