【Xiao Ming's Hope】【HDU - 4349】(卢卡斯定理)

版权声明:本人原创,未经许可,不得转载 https://blog.csdn.net/qq_42505741/article/details/83758194

题目:
 

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers. When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

Input

Each line contains a integer n(1<=n<=10 8)

Output

A single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).

Sample Input

1
2
11

Sample Output

2
2
8

解题报告: 刚上来就有人在我身边说是卢卡斯定理,后来就做这道题目,发现这个实质就是这个数字的二进制中有1的个数,看似和卢卡斯定理没啥关系,实际上就是C(n,m)%2,进行的卢卡斯优化,C(n,m)%2=Lucs(n/2,m/2)*C(n%2,m%2)%p;

所以最后实现的出来就是等价于2的二进制数的1的数目次方。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;

int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int num=0;
		ll sum=1;
		while(n)
		{
			if(n&1)
				num++;
			n>>=1;
		}
		for(int i=0;i<num;i++)
		{
			sum*=2;
		}
		printf("%lld\n",sum);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/83758194