5----逃离迷宫(bfs(宽搜))

逃离迷宫

 给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符’.’表示该位置为空地,字符’*’表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input
2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3
Sample Output
no
yes
#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;
char s[105][105];
int a[105][105];
int qw[4][2]={1,0,0,1,-1,0,0,-1};
int m,n;
int k,x1,y1,x2,y2;
struct node
{
    int x,y,step;
}asd,t;
void bfs()
{
    queue<node>st;
    asd.x=x1;
    asd.y=y1;
    asd.step=-1;
    st.push(asd);
     a[asd.x][asd.y]=1;
    while(!st.empty())
    {
        asd=st.front();
        st.pop();
        if(asd.x==x2&&asd.y==y2&&asd.step<=k)
        {
            cout<<"yes"<<endl;
            return;
        }
        for(int i=0;i<4;i++)
        {
            t.x=asd.x+qw[i][0],t.y=asd.y+qw[i][1];
            while(t.x>0&&t.x<=m&&t.y>0&&t.y<=n&&s[t.x][t.y]!='*')
            {
                if(!a[t.x][t.y])
                {
                    t.step=asd.step+1;
                    a[t.x][t.y]=1;
                    st.push(t);
                }
                t.x=t.x+qw[i][0];t.y=t.y+qw[i][1];
            }
        }
    }
    cout<<"no"<<endl;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(a,0,sizeof(a));
        scanf("%d %d",&m,&n);
        for(int i=1;i<=m;i++)
        {
            scanf("%s",s[i]+1);//注意写法,使其从s[][1]开始存储
        }
        cin>>k>>y1>>x1>>y2>>x2;
        bfs();
    }
    return 0;
}

此题解法:使每一次移动都移动到头或遇到“*”,将经过的坐标录入队列,同时做好标记,是已经录入的不再重复录入
对于四个方向移动的问题,一般都是先提前写好一个数组,存放方向坐标

猜你喜欢

转载自blog.csdn.net/Nacht_one/article/details/81773431