4----Find The Multiple(bfs(宽搜))

Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
using namespace std;
int n;
void bfs()
{
    queue<long long>st;
    st.push(1);
    long long t;//此题最大的数对不会超过20位,用longlong就能解决
    while(!st.empty())
    {
        t=st.front();
        st.pop();
        if(t%n==0)
        {
            cout<<t<<endl;
            return;
        }
        st.push(t*10);
        st.push(t*10+1);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        bfs();
    }
}

因题目要求,此题输出结果只要符合整除关系就行,运行结果与题目给出的有出入
题目较简单,主要是思想

猜你喜欢

转载自blog.csdn.net/Nacht_one/article/details/81745096