ACM-ICPC 2018 焦作赛区网络预赛 B. Mathematical Curse 动态规划

博客目录

原题

题目传送门

  •  22.08%
  •  1000ms
  •  65536K

A prince of the Science Continent was imprisoned in a castle because of his contempt for mathematics when he was young, and was entangled in some mathematical curses. He studied hard until he reached adulthood and decided to use his knowledge to escape the castle.

There are NN rooms from the place where he was imprisoned to the exit of the castle. In the i^{th}ith room, there is a wizard who has a resentment value of a[i]a[i]. The prince has MM curses, the j^{th}jth curse is f[j]f[j], and f[j]f[j] represents one of the four arithmetic operations, namely addition('+'), subtraction('-'), multiplication('*'), and integer division('/'). The prince's initial resentment value is KK. Entering a room and fighting with the wizard will eliminate a curse, but the prince's resentment value will become the result of the arithmetic operation f[j]f[j] with the wizard's resentment value. That is, if the prince eliminates the j^{th}jth curse in the i^{th}ith room, then his resentment value will change from xx to (x\ f[j]\ a[i]x f[j] a[i]), for example, when x=1, a[i]=2, f[j]=x=1,a[i]=2,f[j]='+', then xx will become 1+2=31+2=3.

Before the prince escapes from the castle, he must eliminate all the curses. He must go from a[1]a[1] to a[N]a[N] in order and cannot turn back. He must also eliminate the f[1]f[1] to f[M]f[M] curses in order(It is guaranteed that N\ge MN≥M). What is the maximum resentment value that the prince may have when he leaves the castle?

Input

The first line contains an integer T(1 \le T \le 1000)T(1≤T≤1000), which is the number of test cases.

For each test case, the first line contains three non-zero integers: N(1 \le N \le 1000), M(1 \le M \le 5)N(1≤N≤1000),M(1≤M≤5) and K(-1000 \le K \le 1000K(−1000≤K≤1000), the second line contains NN non-zero integers: a[1], a[2], ..., a[N](-1000 \le a[i] \le 1000)a[1],a[2],...,a[N](−1000≤a[i]≤1000), and the third line contains MM characters: f[1], f[2], ..., f[M](f[j] =f[1],f[2],...,f[M](f[j]='+','-','*','/', with no spaces in between.

Output

For each test case, output one line containing a single integer.

样例输入复制

3
2 1 5
2 3
/
3 2 1
1 2 3
++
4 4 5
1 2 3 4
+-*/

样例输出复制

2
6
3

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

思路

动态规划,设状态dp[i][j]表示取前i个数,j个字符时能获得的最值(最大和最小值都要维护)

设mul(dp,i,j)表示之前的结果为dp,第i个数字第j个运算符运算后的结果

有转移方程:

dpmax[i][j]=max(dpmax[i-1][j],mul(dpmax[i-1][j-1],i,j),mul(dpmin[i-1][j-1],i,j))

//别忘了负数乘以负数可能会转移到最大值。最小值同理。

dpmin同上(详见代码)

边界自然是

dpmax=-inf

dpmin=inf

dp[i][0]=k

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll dpmin[1005][10];
ll dpmax[1005][10];
ll const inf=0x3f3f3f3f3f3f;

int numb[1005];
char s[10];
inline ll mul(ll v,int i,int j){
    switch(s[j]){
        case '+':return v+numb[i];
        case '-':return v-numb[i];
        case '*':return v*numb[i];
        case '/':return v/numb[i];
    }
    return 0;
}
int main(){
    int T;
    cin>>T;
    int n,m,k;
    while(T--){
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1;i<=n;i++){
            scanf("%d",numb+i);
        }
        for(int i=0;i<=n;i++){
            for(int j=0;j<=m;j++){
                dpmax[i][j]=-inf;
                dpmin[i][j]=inf;
            }
        }
        dpmin[0][0]=dpmax[0][0]=k;
        getchar();
        gets(s+1);
        for(int i=1;i<=n;i++){
            dpmin[i][0]=k;
            dpmax[i][0]=k;
            for(int j=1;j<=m;j++){
                dpmin[i][j]=dpmin[i-1][j]; 
                dpmax[i][j]=dpmax[i-1][j]; 
                if(dpmax[i-1][j-1]!=-inf)
                    dpmax[i][j]=max(dpmax[i][j],mul(dpmax[i-1][j-1],i,j));
                if(dpmin[i-1][j-1]!=inf)
                    dpmax[i][j]=max(dpmax[i][j],mul(dpmin[i-1][j-1],i,j));
            
                if(dpmin[i-1][j-1]!=inf)
                    dpmin[i][j]=min(dpmin[i][j],mul(dpmin[i-1][j-1],i,j));    
                if(dpmax[i-1][j-1]!=-inf)
                    dpmin[i][j]=min(dpmin[i][j],mul(dpmax[i-1][j-1],i,j));
            
            }
        }
        cout<<dpmax[n][m]<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/GreyBtfly/article/details/82716077