POJ 3104 二分 坑

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

晾衣服:n件衣服各含a_i水分,自然干一分钟一单位,放烘干机一分钟k单位,一次只能晒一件。求最短时间。(在用烘干机的时候是没有蒸发这一部分水分的!!!!表示自己已经入坑)

然后二分枚举时间:

时间从1--max(a[i])之间枚举时间,如果是时间大于当前的a[i],就是说明该衣服完全可以自己蒸发干,那就不需要放入干燥机里,然后剩下的就是处理水分大于枚举的这个mid了,然后就是两个细节!!

①每分钟烘干k单位的水,于是我就想当然地除k向上取整了((a_i – mid) / k)。其实应该除以k-1,列个详细的算式:

设需要用x分钟的机器,那么自然风干需要mid – x分钟,x和mid需要满足:

k*x + (mid – x) >= a_i,即 x >= (a_i – mid) / (k – 1)。

②当k=1的时候,很显然会发生除零错误,需要特殊处理。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include<set>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
const int N=1e6+400;
int n;
ll k;
ll a[N];
bool cut(ll l){
    ll temp=0;
    rep(i,1,n)
    if(a[i]>l) temp+=ceil((a[i]-l)*1.0/(k-1));//表示相除的结果需要相除的结果需要取整
                                                //使用ceil函数。ceil(x)返回的是大于x的最小整数。
    return temp<=l;
}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    scanf("%d",&n);
    ll r=0,l=0;
    rep(i,1,n)
    scanf("%lld",&a[i]),r=max(a[i],r);
    scanf("%lld",&k);
    if(k==1) {printf("%lld\n",r);return 0;}
    ll ans=0;
        while(r-l>1){
        ll mid=(l+r)/2;
        if(cut(mid))
        r=mid;
        else
        l=mid;
    }
    printf("%lld\n",r);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/83188293