POJ3071:Football(概率DP)

原题 Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input
The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output
The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1
Sample Output
2
Hint
In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that ****team 2 wins the tournament in this case is:
**P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.**
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.
题目意思(有点多,直接上百度翻译)
在一个单一的淘汰赛中,涉及2N个队,表示1, 2,…,2n。在比赛的每一轮中,所有在比赛中的球队都按增加指数的顺序排列在一个列表中。然后,名单中的第一支球队打第二支球队,第三支球队打第四支球队等等。这些比赛的胜利者进入下一轮,失败者被淘汰。在N回合之后,只有一支球队保持不败,这支球队被宣布为胜利者。
给定一个矩阵P=(Pijj),这样Pij是球队在一场比赛中击败J队的概率,决定哪支球队最有可能赢得比赛。(注:获得冠军的概率最大)
输出最大概率的球队序号。

思路
- 每次比赛剩余比赛前一半的队伍数,比赛队伍数 变化为 2^n 2^n-1 …… 1(2^0)即需要参加n次比赛才能选出最后胜利者。
- 每i次比赛在1-2^I,2^i+1-2*2^i,等等 每个区间剩余两只队伍进行比赛,所以关键在于判断两支队伍在第i次比赛时有没有相遇的可能。下面细讲
- 每I 次比赛,队伍j遇到队伍k 获胜的概率为dp[j][i]=dp[j][i-1]*dp[k][i-1]*a[j][k]; 枚举所有情况为 dp[j][i]=dp[j][i]+dp[j][i-1]*dp[k][i-1]*a[j][k]; 注:dp[队伍序号][第i比赛 ]

1 2 3 4 除以2变为
0 1 1 2
其中有3个数
如果变成0 1 2 3 (将数字减一) 除以2变为
0 0 1 1只有两个数 少了一个数
0 1 2 3 4 5 6 7 除以4为
0 0 0 0 1 1 1 1
由此可以推出 第i次比赛时 两只队伍 比赛的队伍j和 k
j2=j(已经减一后的队伍序号)>>(i-1);k2=k(已经减一后的队伍序号)>>(i-1); j2和k2相差了1 &&奇数大于偶数
即 if(j!=k)
{
j2=j>>(i-1); k2=k>>(i-1);
if(j2%2==1) j2–;
else k2–;
if(j2==k2)
dp[j][i]=dp[j][i]+dp[j][i-1]*dp[k][i-1]*a[j][k];
}

 #include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
double dp[159][159],a[159][159];
int main()
{
      int n,m,i,j,k,k1,j1,ans,j2,k2;
      double maxn;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)  break;
        m=pow(2,n);
        for(i=0;i<m;i++)
        for(j=0;j<m;j++)
        scanf("%lf",&a[i][j]);
        memset(dp,0,sizeof(dp));
        for(i=0;i<m;i++)  dp[i][0]=1.000;
        for(i=1;i<=n;i++)
        for(j=0;j<m;j++)
        for(k=0;k<m;k++)
        {
            if(j!=k)
            {
                j2=j>>(i-1);
                k2=k>>(i-1);
                //printf("%d %d %d %d %d %d %d\n",j,k,i,j1,k1,j2,k2);
          if(j2%2)
              j2--;
          else
              k2--;
              if(j2==k2)
                    dp[j][i]=dp[j][i]+dp[j][i-1]*dp[k][i-1]*a[j][k];
            }
        }
        maxn=0;
        for(i=0;i<m;i++)
        {
            if(maxn<=dp[i][n])
            {
                maxn=dp[i][n];
                ans=i;
            }
        }
        printf("%d\n",ans+1);
    }
    return 0;
}  

大家有问题留言即可,一定会耐心解答。

猜你喜欢

转载自blog.csdn.net/xiaoshazheng/article/details/81288794