有依赖的背包

Problem Description

FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.

Input

The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)

Output

For each test case, output the maximum value FJ can get

Sample Input
3 800
300 2 30 50 25 80
600 1 50 130
400 3 40 70 30 40 35 60
 

Sample Output
210

题意:FJ要去购物,买的商品要用箱子装起来,每个箱子装不同的商品,问FJ能获得的最大价值;

只有先买了箱子,才能买固定的物品,所以这是个有依赖的背包问题,对于每个箱子内的物品一定是按01背包看是否要买;

对于每个箱子有两个状态,买,不买;买了就必定买了对应商品,那么买了这一箱子后,用剩下的钱买商品;
代码:
 

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int dp[maxn], temp[maxn];
int main(){
	int n, w;
	while(~scanf("%d%d", &n, &w)){
		//printf("n: %d   w: %d\n", n, w);
		memset(dp, 0, sizeof(dp));
		for(int i=1; i<=n; i++){
			memcpy(temp, dp, sizeof(dp));
			int p, m;
			scanf("%d%d", &p, &m);
			//printf("p: %d   m: %d\n", p, m);
			for(int k=1; k<=m; k++){
				int c, v;
				scanf("%d%d", &c, &v);
				//printf("c:%d  v:%d\n", c, v);
				for(int j=w-p; j>=c; j--){
					temp[j]=max(temp[j], temp[j-c]+v);
				}
			}
			for(int j=p; j<=w; j++){
				dp[j]=max(dp[j], temp[j-p]);
			}
		}
		printf("%d\n", dp[w]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/86302728