PAT B1020

1020 月饼 (25 分)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

 NOTE:

1. double 型数据用 %f 输出 !!!

2.强制类型转换只需转换被除数,并带上括号

#include <stdio.h>
#include <algorithm>
using namespace std;
struct Moon{
	double kucun;
	double total_price;
	double unit_price;
}moon[1010];
bool cmp(Moon a, Moon b){
	return a.unit_price > b.unit_price;
}
int main(){
	int n, d;
	scanf("%d %d", &n, &d);
	for(int i = 0; i < n; i++){
		scanf("%lf", &moon[i].kucun);
	}	
	for(int i = 0; i < n; i++){
		scanf("%lf", &moon[i].total_price);
		moon[i].unit_price = ((double)moon[i].total_price) / moon[i].kucun;
	}
	sort(moon, moon+n, cmp);
	double sum;
	for(int i = 0; i < n; i++){
		if(moon[i].kucun >= d){
			sum += d * moon[i].unit_price;
			break;
		}
		else if(moon[i].kucun < d){
			sum += moon[i].kucun * moon[i].unit_price;
			d = d - moon[i].kucun;
		}
	}
	printf("%.2f", sum);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gsj9086/article/details/86605365