拓扑排序 确定排名

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。 

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。 

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。 

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。 

Sample Input

4 3
1 2
2 3
4 3

Sample Output

1 2 4 3

输出的是排名!利用拓扑排序建立图形,然后利用优先队列输出即可

#include <queue>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
#include <functional>
using namespace std;

const int maxn = 6000 + 66;

int res[maxn];
int n, m, in[maxn];
int vis[maxn][maxn];
vector<int> ans, vec[maxn];

bool toposort()
{
    int p, v, len;

    priority_queue<int, vector<int>, greater<int> > q;
    while(!q.empty())
        q.pop();
    for(int i = 1; i <= n; ++i)
    {
        if(!in[i])
            q.push(i);
    }

    while(!q.empty())
    {
        p = q.top();
        ans.push_back(p);
        q.pop();

        len = vec[p].size();
        for(int i = 0; i < len; ++i)
        {
            v = vec[p][i];
            --in[v];
            if(!in[v])
                q.push(v);
        }
    }

    if(ans.size() == n)
        return true;
    else
        return false;
}
int main()
{
    int t, a, b;
    while(scanf("%d%d", &n, &m)!=EOF)
    {

        memset(in, 0, sizeof(in));
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i <= n; ++i)
            vec[i].clear();

        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d", &a, &b);
            if(!vis[a][b])
            {
                vec[a].push_back(b);
                vis[a][b] = 1;
                ++in[b];
            }
        }
        ans.clear();
        if(toposort())
        {
            int len = ans.size();
            for(int i = 0; i < n; ++i)
            {
                printf("%d%c", ans[i], (i == n-1 ? '\n' : ' '));
            }
        }
        else
            puts("-1");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/87902868