PAT A1067 Sort with Swap(0, i) +运行超时

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

代码:

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;
    int pos[n];
    int k;
    for(int i=0;i<n;i++){
        scanf("%d",&k);
        pos[k]=i;
    }
    int swaps=0;
    int i=1; //表示不再本位的第一个数
    while(true){
        if(pos[0]!=0){  //如果0不在本位,要交换次数最少,直接与数字pos[0]所在的位置交换
            k=pos[pos[0]];
            pos[pos[0]]=pos[0];
            pos[0]=k;
            swaps++;
        }
        else{   //0在本位,需要与不再本位的数交换,才能继续排序
            for(;i<n && pos[i]==i;i++){
            }
            //从不在本位的第一个数开始找起,不再是每次从1开始找了
            //那样会超时
            if(i==n)   //如果都在本位了,说明排完了
                break;
            else{
                k=pos[i];
                pos[i]=pos[0];
                pos[0]=k;
                swaps++;
            }
        }
    }
    printf("%d",swaps);
    return 0;
}

注:运行超时的原因是第一次找不在本位的第一个数是1开始寻找,导致时间复杂度为O(n^2),如果用k记录不在本位的第一个数,可降低到O(n),不会出现运行超时。

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/87799786