【洛谷1137】旅行计划【拓扑排序模板】

Description

小明要去一个国家旅游。这个国家有N个城市,编号为1至N,并且有M条道路连接着,小明准备从其中一个城市出发,并只往东走到城市i停止。

所以他就需要选择最先到达的城市,并制定一条路线以城市i为终点,使得线路上除了第一个城市,每个城市都在路线前一个城市东面,并且满足这个前提下还希望游览的城市尽量多。

现在,你只知道每一条道路所连接的两个城市的相对位置关系,但并不知道所有城市具体的位置。现在对于所有的i,都需要你为小明制定一条路线,并求出以城市ii为终点最多能够游览多少个城市。

Input

第11行为两个正整数N, M。

接下来M行,每行两个正整数x, y表示了有一条连接城市x与城市y的道路,保证了城市x在城市y西面。

Output

N行,第i行包含一个正整数,表示以第ii个城市为终点最多能游览多少个城市。

Sample input

5 6
1 2
1 3
2 3
2 4
3 4
2 5

Sample output

1
2
3
4
3

hint

均选择从城市1出发可以得到以上答案。

对于20%的数据,N ≤ 100

对于60%的数据,N ≤ 1000N≤1000;

对于100%的数据,N ≤ 100000,M ≤ 200000;

分析

这题是一道拓扑排序模板题。认真理解一下PPT里的内容即可(背好板子)。

扫描二维码关注公众号,回复: 9369075 查看本文章

上代码

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,m,d[100001],tot,f[100010],b[100010];
struct node
{
	int next,to;
}a[400010];
queue<int>q;
void topsort()
{
	for(int i=1;i<=n;i++)
	{
		if(!b[i])//找到一个入度为0的节点 
		{
			f[i]=1;
			q.push(i);//入队,开始拓扑排序 
		}
	}
	while(!q.empty())
	{
		int x=q.front();
		q.pop();
		for(int i=d[x];i;i=a[i].next)
		{
			f[a[i].to]=max(f[a[i].to],f[x]+1);
			if(!--b[a[i].to]) q.push(a[i].to);
		}
	}
}
int main()
{ 
	ios::sync_with_stdio(false);
	cin>>n>>m;
	for(int i=1;i<=m;i++)
	{
		int x,y;
		cin>>x>>y;
		a[++tot].to=y;
		a[tot].next=d[x];
		d[x]=tot;
		b[y]++;
	}
	topsort();
	for(int i=1;i<=n;i++)
	{
		cout<<f[i]<<endl;
	}
	return 0;
}
发布了63 篇原创文章 · 获赞 61 · 访问量 5480

猜你喜欢

转载自blog.csdn.net/dglyr/article/details/104024777