POJ 1584 A Round Peg in a Ground Hole

POJ 1584 A Round Peg in a Ground Hole

Description

The DIY Furniture company specializes in assemble-it-yourself furniture kits. Typically, the pieces of wood are attached to one another using a wooden peg that fits into pre-cut holes in each piece to be attached. The pegs have a circular cross-section and so are intended to fit inside a round hole.
A recent factory run of computer desks were flawed when an automatic grinding machine was mis-programmed. The result is an irregularly shaped hole in one piece that, instead of the expected circular shape, is actually an irregular polygon. You need to figure out whether the desks need to be scrapped or if they can be salvaged by filling a part of the hole with a mixture of wood shavings and glue.
There are two concerns. First, if the hole contains any protrusions (i.e., if there exist any two interior points in the hole that, if connected by a line segment, that segment would cross one or more edges of the hole), then the filled-in-hole would not be structurally sound enough to support the peg under normal stress as the furniture is used. Second, assuming the hole is appropriately shaped, it must be big enough to allow insertion of the peg. Since the hole in this piece of wood must match up with a corresponding hole in other pieces, the precise location where the peg must fit is known.
Write a program to accept descriptions of pegs and polygonal holes and determine if the hole is ill-formed and, if not, whether the peg will fit at the desired location. Each hole is described as a polygon with vertices (x1, y1), (x2, y2), . . . , (xn, yn). The edges of the polygon are (xi, yi) to (xi+1, yi+1) for i = 1 . . . n − 1 and (xn, yn) to (x1, y1).

Input

Input consists of a series of piece descriptions. Each piece description consists of the following data:
Line 1 < nVertices > < pegRadius > < pegX > < pegY >
number of vertices in polygon, n (integer)
radius of peg (real)
X and Y position of peg (real)
n Lines < vertexX > < vertexY >
On a line for each vertex, listed in order, the X and Y position of vertex The end of input is indicated by a number of polygon vertices less than 3.

Output

For each piece description, print a single line containing the string:
HOLE IS ILL-FORMED if the hole contains protrusions
PEG WILL FIT if the hole contains no protrusions and the peg fits in the hole at the indicated position
PEG WILL NOT FIT if the hole contains no protrusions but the peg will not fit in the hole at the indicated position

Sample Input

5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.0
1.0 3.0
0.0 2.0
5 1.5 1.5 2.0
1.0 1.0
2.0 2.0
1.75 2.5
1.0 3.0
0.0 2.0
1

Sample Output

HOLE IS ILL-FORMED
PEG WILL NOT FIT

题目不难,就是套套模板:
1.判断是否为凸多边形
2.判断圆心是否在凸多边形内
3.判断圆是否能被凸多边形包含
P S PS :模板要找好一点的,因为这个一直找不到错误

#include<algorithm>
#include<cmath>
#include<iostream>
#include<cstdio>
using namespace std;
typedef long long ll;
double eps=1e-8;

struct point{
    double x,y;
}p[1005];

int sgn(double x)
{
    if(fabs(x) < 0) return 0;
    else return x < 0 ? -1 : 1;
}

double cross(point a,point b,point c){
    return (a.x-c.x)*(b.y-c.y)-(a.y-c.y)*(b.x-c.x);
}

bool isConvex(point *p,int n)//判断是否是凸包
{
    p[n++]=p[0];
    p[n++]=p[1];
    int dir =cross(p[1],p[2],p[0])<0?1:0;
    for(int i=3; i<n; i++)
        if((cross(p[i-1],p[i],p[i-2])<0?1:0)!=dir)
            return false;
    return true;
}

bool isPointInConvex(point *p, int n, point point)
{
    bool flag = true;
    p[n] = p[0];
    int now = sgn(cross(p[0],p[1],point));
    for(int i = 1; i < n; i++)
    {
        int next =sgn(cross(p[i],p[i+1],point));
        if(next*now < 0)
        {
            flag = false;
            break;
        }
        now = next;
    }
    return flag;
}

double Distance(point p1,point p2){
return (sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y)));
}

double dis(point p,point s,point e)
{
 return fabs(cross(p,s,e))/Distance(s,e);
}

int main(){
    int n;
    double r;
    point c;
    while(cin>>n && n>=3){
        cin>>r>>c.x>>c.y;
        for(int i=0;i<n;i++) cin>>p[i].x>>p[i].y;
        if(!isConvex(p,n)) puts("HOLE IS ILL-FORMED");
        else{
            int flag=1;
            for(int i=0;i<n;i++){
                if(r-dis(c,p[i],p[(i+1)%n])>eps){
                    flag=0;
                    break;
                }
            }
            if(flag && isPointInConvex(p,n,c)) puts("PEG WILL FIT");
            else puts("PEG WILL NOT FIT");
        }
    }
	return 0;
}
发布了296 篇原创文章 · 获赞 15 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_43765333/article/details/104423796