hdu 3033 I love sneakers! 分组背包

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store. 

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand. 
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice. 
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
InputInput contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File. OutputFor each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied. Sample Input
5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66
Sample Output

255

分组背包
有N件物品和一个容量为V的背包。第i件物品的费用是c[i],价值是w[i]。
这些物品被划分为若干类,每类中的物品互相冲突,最多选一件


题意:就数据而言,5件物品,总钱数为10000,物品分为3类

物品种类为1,花费为4,价值为6

物品种类为2,花费为5,价值为7

等等。。。

求在总钱数内每件物品至少买一件的最大价值,如果不能买,输出Impossible

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MAXS 11 //种类数的最大值
#define MAXN 110 //每种类中的总个数最大值
#define MAXM 10010
using namespace std;
int num[MAXS];//统计该种类已有多少个
int cost[MAXS][MAXN];//该种类中该物品的花费
int val[MAXS][MAXN];//该种类中该物品的价值
int dp[MAXS][MAXM];
int main()
{
    int n,m,s;
    while(~scanf("%d%d%d",&n,&m,&s))//n件物品,m为总钱数,分为s类
    {
        memset(num,0,sizeof(num));
        int a,b,c;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&a,&b,&c);//该件物品的种类  花费  价值
            cost[a][num[a]]=b;
            val[a][num[a]]=c;
            num[a]++;
        }
        for(int i=0; i<=s; i++)
            for(int j=0; j<=m; j++)
            {
                if(i==0)
                    dp[i][j]=0;
                else
                    dp[i][j]=-1;
            }
        for(int i=0; i<=s; i++)
        {
            for(int j=0; j<num[i]; j++)
            {
                for(int k=m; k>=cost[i][j]; k--)
                {
                //当前的值,要这种不要这件之前的值加上物品价值,没有要这种且没有要这件时的值加上物品价值,
                    if(dp[i][k-cost[i][j]]!=-1)
                        dp[i][k]=max(dp[i][k],dp[i][k-cost[i][j]]+val[i][j]);
                    if(dp[i-1][k-cost[i][j]]!=-1)
                        dp[i][k]=max(dp[i][k],dp[i-1][k-cost[i][j]]+val[i][j]);
                }
            }
        }
         if(dp[s][m]<0)
            printf("Impossible\n");
        else
            printf("%d\n",dp[s][m]);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/zch3210/article/details/70255833