HDU 3033 I love sneakers!

版权声明:欢迎转载ヽ(•ω•ゞ)···如有表意不清或您没有看懂评论即可! https://blog.csdn.net/yandaoqiusheng/article/details/84868978

题目链接:传送门
题面:

I love sneakers!

Problem Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print “Impossible” if Iserlohn’s demands can’t be satisfied.

Sample Input

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66

Sample Output

255

题目大意:
一共有 K K 种品牌, n n 种运动鞋,每种运动鞋的品牌会在输入中给出,你有 m m 元钱,每种运动鞋有自己的价值和价格,每组品牌的运动鞋至少要买一件,求最大价值

每次输入运动鞋的时候记录下它的分组
记下每个分组有多少个运动鞋
下面就跟普通的板子不同了
要先把 f f 数组初始化为 1 -1
第一次取每组中的物品时必须由之前的结果推知
代码中有解释

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <complex>
#include <algorithm>
#include <climits>
#include <queue>
#include <map>
#include <vector>
#include <iomanip>
#define A 1000010
#define B 2010
#define ll long long

using namespace std;
int n, V, k, bl[11], f[11][10010], w[11][110], v[11][110], a, b, c;

int main() {
    while (cin >> n >> V >> k) {
        memset(bl, 0, sizeof bl);
        memset(f, 0, sizeof f); bl[0] = 1;
        for (int i = 1; i <= n; i++) {
            cin >> a >> b >> c;
            w[a][bl[a]] = b;
            v[a][bl[a]] = c;
            bl[a]++;
        }
        for (int i = 0; i <= k; i++)
          for (int j = 0; j <= V; j++)
            f[i][j] = (!i) ? 0 : -1;
        for (int i = 1; i <= k; i++)
          for (int j = 0; j < bl[i]; j++)
            for (int l = V; l >= w[i][j]; l--) { //f[i][l]是不选择当前的鞋子
                if (f[i][l - w[i][j]] != -1)  //f[i][l - w[i][j]]是选择当前的鞋子并且不是第一次选
                  f[i][l] = max(f[i][l], f[i][l - w[i][j]] + v[i][j]);
                if (f[i - 1][l - w[i][j]] != -1)  //f[i - 1][l - w[i][j]]是选择当前的鞋子并且是第一次选,都要从前面转移过来,所以初值为-1
                  f[i][l] = max(f[i][l], f[i - 1][l - w[i][j]] + v[i][j]);
                }
        if (f[k][V] < 0) puts("Impossible");
        else cout << f[k][V] << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/yandaoqiusheng/article/details/84868978