畅通工程 最小生成树 普里姆实现

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5


        
  
Huge input, scanf is recommended.

Hint

Hint

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5


        
  
Huge input, scanf is recommended.

Hint

Hint

#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<string>
#include<queue>
#include<vector>
#include <utility>
#include <functional>
#include <algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=105;
typedef pair<int,int>  pii;
int n;
bool s[maxn];
int g[maxn][maxn];
priority_queue<pii,vector<pii>,greater<pii> >q;
int prim()
{     

    int ans=0,cnt=0,b,c;
    memset(s,0,sizeof(s) );
    s[1]=true;
    for(int i=1;i<=n;i++)
    {
        if(g[1][i]==inf)continue;
        q.push(make_pair(g[1][i],i));
    }
    while(cnt<n-1)
    {
        b=q.top().second;
        c=q.top().first;
        q.pop();
        if(s[b])continue;
        s[b]=true;
        cnt++;
        ans+=c;
        for(int i=1;i<=n;++i)
        {
            if(s[i])continue;
            if(g[b][i]==inf)continue;
            q.push(make_pair(g[b][i],i));
        }    
    }
    return ans;
}
int main()
{
 
    while(~scanf("%d",&n)&&n)
    {    memset(g,0x3f,sizeof(g));
        while (!q.empty()) q.pop();//每次循环要清空q 
    int m,a,b,c;
    m=n*(n-1)/2;
    for(int i=0;i<m;i++)
    {
    scanf("%d%d%d",&a,&b,&c);
    g[a][b]=g[b][a]=c;//邻接矩阵无向图 

    }
    printf("%d\n",prim());    
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41932243/article/details/81189349