HDUOJ2046:骨牌铺方格

版权声明:qq836678589 https://blog.csdn.net/weixin_43924623/article/details/91391285

骨牌铺方格

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 74273 Accepted Submission(s): 35642

Problem Description
在2×n的一个长方形方格中,用一个1× 2的骨牌铺满方格,输入n ,输出铺放方案的总数.
例如n=3时,为2× 3方格,骨牌的铺放方案有三种,如下图:

在这里插入图片描述

Input
输入数据由多行组成,每行包含一个整数n,表示该测试实例的长方形方格的规格是2×n (0<n<=50)。

Output
对于每个测试实例,请输出铺放方案的总数,每个实例的输出占一行。

Sample Input
1
3
2

Sample Output
1
3
2

#include<iostream>
using namespace std;
int main(){
	int n,a,b;
	long long  ar[51]={0,1,2,3};
	for(int i=4;i<=50;i++)
		ar[i]=ar[i-1]+ar[i-2];
	while(cin>>n){
		cout<<ar[n]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43924623/article/details/91391285