HDU-2602 Bone Collector(01背包)

HDU-2602 Bone Collector(01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
 
  
15 101 2 3 4 55 4 3 2 1
 
Sample Output
 
  
14
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1203  2159  2955  1171  2191 


01背包就是取还是不取的问题


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define MAXN 1010
int dp[MAXN][MAXN];  //dp[i][j]表示i个物品,体积为j时的最大价值
int value[MAXN],w[MAXN];
int main()
{
   int t;
   int n,v;
   int i,j;
   scanf("%d",&t);
   while(t--)
   {
     memset(dp,0,sizeof(dp));
     scanf("%d%d",&n,&v);
     for(i=1;i<=n;i++)
     scanf("%d",&value[i]);
     for(i=1;i<=n;i++)
     scanf("%d",&w[i]);
     for(i=1;i<=n;i++)
     for(j=v;j>=0;j--)          //体积是从大到小变化的,
     {
         dp[i][j]=dp[i-1][j];   //一开始是没这个物品的
         if(j>=w[i])
         dp[i][j]=max(dp[i][j],dp[i-1][j-w[i]]+value[i]);
     }
     cout<<dp[n][v]<<endl;
   }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/80778770