HDU-2602 Bone Collector(01背包)

版权声明:emmmmm喵喵喵 https://blog.csdn.net/MallowFlower/article/details/84875913

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

 

1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

 

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

典型的01背包

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace  std;
long long dp[2000][2000];
int v[2000];
int w[2000];
long long max(long long a,long long b){
    if(a>b){
        return a;
    }else{
        return b;
    }
}
int main(){
    //ios::sync_with_stdio();
    int n;
    cin>>n;
    int a,b;
    while(n--){
        memset(dp,0,sizeof(dp));
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        cin>>a>>b;
        for(int i=1;i<=a;i++){
            cin>>v[i];
        }
        for(int i=1;i<=a;i++){
            cin>>w[i];
        }
        for(int i=1;i<=a;i++){
            for(int j=0;j<=b;j++){
                if(j<w[i]){
                    dp[i][j]=dp[i-1][j];
                    continue;
                }else{
                    //long long num1=dp[i-1][j-w[i]]+v[i];
                    //long long num2=dp[i-1][j];
                    //dp[i][j]=max(num1,num2);
                    dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);
                }
            }
        }
        
        cout<<dp[a][b]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/MallowFlower/article/details/84875913