HDU - 2602—Bone Collector(01背包)

版权声明:沃斯里德小浩浩啊 https://blog.csdn.net/Healer66/article/details/82463535

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

最经典的01背包了。

#include <bits/stdc++.h>
using namespace std;
const  int  maxn = 1e3+10;
int dp[maxn];
int val[maxn];
int vol[maxn];
int  t;
void init()
{
    memset(dp,0,sizeof dp);
    memset(val,0,sizeof val);
    memset(vol,0,sizeof vol);
}
int main()
{
    cin>>t;
    while(t--)
    {
        init();
        int n,w;
        cin>>n>>w;
        for(int i=1;i<=n;i++)
        {
            cin>>val[i];
        }
          for(int i=1;i<=n;i++)
        {
            cin>>vol[i];
        }
        for(int i=1;i <= n; i++)
        {
            for(int j=w;j>=vol[i];j--)
            dp[j]=max(dp[j],dp[j-vol[i]]+val[i]);

        }
        cout<<dp[w]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Healer66/article/details/82463535