HDU2602 Bone Collector【01背包】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 86567    Accepted Submission(s): 35776


 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

Author

Teddy

Source

HDU 1st “Vegetable-Birds Cup” Programming Open Contest

问题链接:HDU2602 Bone Collector

解题思路:01背包模板题

AC的C++代码:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N=1005;
int c[N],p[N];//分别存储费用和价值
int dp[N]; 

int main()
{
	int t,N,V;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&N,&V);
		for(int i=0;i<N;i++)
		  scanf("%d",&p[i]);
		for(int i=0;i<N;i++)
		  scanf("%d",&c[i]);
		memset(dp,0,sizeof(dp));
		for(int i=0;i<N;i++)
		  for(int j=V;j>=c[i];j--)
		    dp[j]=max(dp[j],dp[j-c[i]]+p[i]);
		printf("%d\n",dp[V]);
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/83747423