A + B Problem Too HDU - 2101(语言训练题)

This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

    Input
    Each line will contain two integers A and B. Process to end of file.

    Output
    For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

    Sample Input
    1 1

8600 8600

    Sample Output
    no
    yes

题目说明:
输入两个数A和B,判断他们的和能否被86整除,若可以,则输出“yes”,否则输出“no”。
程序说明:
用cin>>a>>b作为while()的参数,可以实现多次输入数据的要求,while()函数内执行if判断语句,看A+B能否被86整除。
程序实现:

#include <iostream>
using namespace std;
int main()
{
    int a, b;
 while (cin >> a >> b)
 {
  if ((a+b)%86)
   cout << "no" << endl;
  else
   cout << "yes" << endl;
  }
}

猜你喜欢

转载自blog.csdn.net/qq_43667011/article/details/84873139