hdu2101——A + B Problem Too

A + B Problem Too

This problem is also a A + B problem,but it has a little
difference,you should determine does (a+b) could be divided with
86.For example ,if (A+B)=98,you should output no for result.

Input

Each line will contain two integers A and B. Process to end of file.

Output

For each case, if(A+B)%86=0,output yes in one line,else output no in
one line.

Sample Input

1 1
8600 8600

Sample Output

no
yes

程序分析:while循环来多次输入,if判断(a+b)是否为86的倍数,!!程序要求换行!!
AC通过程序:

#include<stdio.h>
int main()
{
	int a,b;
	while(scanf("%d %d",&a,&b)!=EOF)
	{
		if((a+b)%86==0)
		{
			printf("yes\n");
		}else printf("no\n");
	}
	return 0;
}

小小改进后:

#include<stdio.h>
int main()
{
	int a,b;
	while(scanf("%d %d",&a,&b)!=EOF)
		(a+b)%86==0?printf("yes\n"):printf("no\n");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43887417/article/details/84867009